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1 Introduction
ADAMS stands for Automatic Dynamic Analysis of Mechanical Systems and was originally developed by Mechanical Dy-
namics Inc.(MDI). MDI was formed by researchers/developers of the original ADAMS code at University of Michigan, Ann
Arbor, MI, USA. Later on, it was absorbed into McNeil Schindler Corp (MSC) in 2002.

At the core of ADAMS is a large displacement code called ADAMS/Solver, that solves nonlinear numerical equations.
Models are built in text format and then submitted into ADAMS/Solver. In the early 90’s, ADAMS/View was released which
allowed users to build, simulate and examine results in a single Graphical User Environment(GUI). Today, MSC produces
many general engineering analysis packages like MSC.NASTRAN, MSC.PATRAN, MSC.DYTRAN etc. and also packages
which cater to industry specific users like MSC.ADAMS/Car, MSC.ADAMS/Rail, MSC.ADAMS/Engine etc. In this tutorial
however, we’ll be dealing with MSC.ADAMS alone.

MSC.ADAMS™ Simulation Package is a powerful modeling and simulating environment that lets one build, simulate,
refine, and ultimately optimize any mechanical system, from automobiles and trains to VCRs and backhoes. This tutorial is
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intended as an introduction to using MSC.DAMS, specifically in the context of robotics, although it’s applications are much
more wider.

2 Using MSC.ADAMS
At the time of writing this tutorial, the running version was ADAMS 2010. The company offers subsidized versions of the
software to students for academic/non-commercial usage. Please check the official site for pricing and other details. Once a
copy is obtained, install the software following the instructions in their installation guide.

2.1 Launching MSC.ADAMS
Once installed, the software may be launched by

1. Windows (All Versions): Start Menu→Programs→MSC.Software→MSC ADAMS(version number)→AView→Adams-
View or just launching the shortcut(if it exists)on the desktop.

2. Linux/Unix:

(a) At the command prompt, enter the command to start the Adams Toolbar, and then press Enter. The standard
command that MSC provides is adamsmdx, where ’x’ is the version number, for example adamsmdr3, which
represents MD Adams R3. The Adams Toolbar appears.

(b) Click the Adams/View tool. For more information on the Adams Toolbar, see Running and Configuring Adams
in ADAMS Help.

2.2 Starting a New Modelling Session
When Adams/View is started, Adams/View displays a Welcome dialog box that lets one create a new modeling database
or use an existing one. The Welcome dialog box also lets one import modeling data and specify the working directory.
Adams/View also displays the Welcome dialog box when one uses the New Database command to create a new modeling
database in which to store your models. The GUI screen with Welcome dialog box is shown below.

Figure 1: ADAMS GUI with Welcome Dialog Box
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Figure 2: ADAMS View Interface

1. Select one of the options explained in the table below to indicate how to start using Adams/View, and then select OK.

Option What it does.
Create a new model and allows one to start a new modeling session with a new modeling database.Follow Steps 2 and 3 to create the new modeling database.
Open an existing database and allows one to open an existing modeling database.Learn about Opening a Modeling Database.
Import a file and allows one to start a new modeling session by reading in a model from an Adams/View command file or an Adams/Solver dataset.
Exit to exit Adams/View without performing an operation.

2. Specify the directory to be used as the working directory. By default, Adams/View searches for and saves all files in
the directory from which one started Adams/View. One can change the working directory at any time.

To change the working directory for the current session:

(a) Set the working directory when starting Adams, from the Welcome Dialog Box, as mentioned earlier.

(b) On the File menu, select Select Directory. Then, select the directory in which Adams/View should save files and
then select OK.

To change the working directory for all sessions:

(a) On Linux/UNIX:

• From the Adams Toolbar, right-click the Adams/View tool, and then select Change Settings.
• In the Registry Editor, select WorkingDirectory, and then change the working directory.

(b) On Windows:

• On the Desktop, right-click the Adams/View shortcut, and then select Properties.
• In the Start In text box, enter the working directory.

2.3 Setting up the Model/ Session Parameters
If Create a new model was selected, then various options to customize the model such as units, gravity etc. need to be fixed
as described below.
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1. In the Model name text box, enter the name to be assigned to the new model. This is limited to 80 alphanumeric
characters and cannot have special characters, such as spaces or periods.

2. Gravity: One can specify the magnitude and direction of the acceleration of gravity. For each part with mass, the
gravitational force produces a point force at its center of mass. To specify the gravity settings for, New Model,

• Earth Normal - Sets the gravity to 1 G(9.812 m/s2) downward.

• No Gravity - Turns off the gravitational force.

• Other - Lets one set the gravity as desired. The Gravity Settings dialog box appears after one selects OK
on the Welcome dialog box.

For any Existing Model, to turn gravity On/Off, select the Settings →Gravity & Tick/Untick the Gravity check
box from the Gravity Settings dialog box. Subusequently, set the acceleration of the gravity in the X, Y , and Z
directions with respect to the global coordinate system. See the table below for assistance. When gravity is turned on,
an icon appears in the middle of the Adams/View main window. To turn off the display of the gravity icon, refer to
MSC help on Edit Appearance dialog box.

3. Select a preset unit system for your model. In all the preset unit systems, time is in seconds and angles are in degrees.
One can set:

• MMKS - Sets length to millimeter, mass to kilogram, and force to Newton.

• MKS - Sets length to meter, mass to kilogram, and force to Newton.

• CGS - Sets length to centimeter, mass to gram, and force to Dyne.

• IPS - Sets length to inch, mass to slug, and force to PoundForce.

If any of the preset unit systems are not desired, one can change the units as required. Detailed instructions are
available in the official Adams/View Help or online at the MSC website.

4. Once done, select OK. Adams/View, then creates a new model. If selected to set gravity when creating a new model,
the Gravity Settings dialog box appears.

2.4 Setting up Coordinate Systems & Rotation Sequences to be used in ADAMS
2.4.1 Coordinate Systems

On first launching Adams/View, it displays a view triad in the lower left corner. The view triad displays the global coordinate
system for the modeling database.

By default, Adams/View uses a Cartesian coordinate system as the global coordinate system with three axes (X, Y ,
and Z). Adams/View attaches the ground part to the global coordinate system and by default positions all other modeling
objects to it. However, the user may customize the software settings to appropriately choose between the three available
Coordinate systems namely Cylindrical, Spherical & Cartesian models, depending on the problem in hand.

2.4.2 Rotation Sequences

Adams/View uses three orientation angles to perform three rotations about the axes of any chosen coordinate system. One
can specify the order in which axes are rotated about as a sequence of three numbers (1,2,3), which correspond to X, Y , and
Z axes (in Cartesian Coorinates), respectively. For example, a rotation order of 312 produces rotations about the Z, then
X, and then Y axis. Adams/View provides a set of 24 rotation sequences from which to choose. The most commonly used
rotation sequence, namely body 313, is the default sequence (For more details on rotation see Module 2).

The figure below shows how successive rotations defined by the rotation angles orient the axes. Dashed lines represent
original orientations and solid lines represent new and unchanged orientations.

Figure 3: ADAMS GUI with Welcome Dialog Box
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• The first angle rotates the coordinate system about its Z axis. This repositions the X axis and the Y axis (see a in
figure).

• The second angle rotates the coordinate system about its new X axis (X´) to reposition the new Y axis (Y´) and the
Z axis (see b in figure).

• The third angle rotates the coordinate system about its new X axis (Z´) to reposition the new X axis (X´) and the
second new Y axis (Y˝).

Together and in sequence(important!), these rotations define the orientation of the coordinate system (see c in figure).
The right-hand rule defines the direction of positive rotation about each axis. For example, if looking down the initial Z
axis, positive rotations are counterclockwise and negative rotations are clockwise.

2.4.3 Modifying the preferences for Coordinate System & Rotation Sequences

To set the default coordinate system, one can do as follows:

1. On the Settings menu, select Coordinate System
OR
On the Move tool stack of the Main toolbox, select the Coordinate System tool . The Coordinate Systems Setting
dialog box appears.

2. Select the type of location coordinate systems: Cartesian, cylindrical, spherical.

3. Select the type of rotation sequence.

4. Select either:

• Space fixed - Adams/View applies the rotations about axes that remain in their original orientation.

• Body fixed - Adams/View applies the rotations about axes that move with the body as it rotates.

As Adams/View applies each rotation to an axis, it produces a new set of axes.

5. Select OK.

2.5 Models and Associated Database Structures
Amodeling database stores all the information on anything and everything one does in the ADAMS environment. Adams/View
stores all the work in modeling databases. The Adams/View modeling database is a hierarchical database. Each object in the
database has an object that owns it, called its parent, and many objects own other objects, called their children. The top level
objects in the database are models, views, plots, and libraries containing such things as dialog boxes. The following shows the
hierarchy of a database called Database_1 that contains one model and a plot of the model. Names of objects in the database

Figure 4: Hierarchical Structure of Modelling Database

use a hierarchical naming structure. For example, a block built on the ground part is named .model_1.ground.block.
One can store more than one model in a modeling database.

2.5.1 Information Window

Adams/View uses the Information window to display many different types of information about your model, simulation,
or motion data. In addition to just viewing information about the model, one can perform a variety of operations in the
Information window. For example, one can display additional information about the current object’s parent or child, print
the information, display information about a different object in the database, and more.
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2.5.2 Database Navigator

The Database Navigator helps one view, select, and modify objects in the modeling database. It also displays the types
of objects appropriate for the command being executed and shows objects in their database hierarchy. One can browse for
objects or set it to rename objects, view information about the objects and view dependencies. The Database Navigator
shows objects in their database hierarchy. The following figure shows the Database Navigator with the top-level modeling
objects in a small database that contains one model, model_1. These objects do not have parents. Double-click the name of a
model, in this case model_1, to find all the objects belonging to that model. The Database navigator opens up automatically

Figure 5: Database Navigator

whenever one does any of the following.

• Select Database Navigator from the Tools menu.

• Execute an editing command, such as Modify, from the Edit menu when no object is currently selected.

• Request to view information about an object using the Info command on the Edit shortcut menu.

• Browse for the name of an object to enter in a dialog box using the Browse command.

2.5.3 Creating a Modeling Database

When one first starts working with Adams/View, it provides options for creating a new modeling database. One can also
create a new modeling database anytime during the Adams/View session. Only one modeling database can be open at a
time, but it can contain multiple models. Do one of the following to Create a new modeling database:

• On the File menu, select New Database.

• On the Standard toolbar, select the New Database tool .

2.5.4 Opening a Modeling Database

To open an existing modeling database do one of the following:

• On the File menu, select Open Database OR

• On the Standard toolbar, select the Open Database tool.

The File Selection dialog box appears. The File Selection filter is set to display only modeling database files (those with a
.bin extension). In the Directories list box, select the directory in which the file is located. Highlight the file that you want
to open in the Files list box, or type the file name in the Selection text box. The highlighted file appears in the Selection
text box. Select OK.

2.5.5 Saving a Modeling Database

The user can use the Save Database command to save the current modeling database as an Adams/View binary file. Saving
the modeling database as a binary file saves all modeling information, including any customization changes made by the
user. To save an existing modeling database:

1. Select one of the following:

• On the File menu, select Save Database.
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• On the Standard toolbar, select the Save Database tool. Before saving the file, Adams/View displays a message
asking the user if it wants to create a backup file of the current database file.

2. Select one of the following:

• Yes - Creates a backup file of the existing database file and saves the database. When Adams/View creates a
backup file, it adds a % to the end of the file extension (for example, model.bin%).

• No - Saves the database without making a backup copy of the existing database file.

• Cancel - Exit the command without saving the database.

One can save the current modeling database to a binary file with a new name. This lets one keep several versions of
the database under different names and reduces the risk of losing the work if one inadvertently change or delete the model.
Assigning a new name can be done by

1. On the File menu, select Save Database As. The Save Database As dialog box appears.

2. In the File Name text box, enter the name you want to assign to the file.

3. Select OK.

2.5.6 Adding a Model to the Current Database

1. On the Build menu, point to Model, and then select New. The Create Model dialog box appears.

2. In the Model Name text box, enter the name of the model.

3. Select whether or not to use the same gravity settings as the current model in the database.

4. Select the Comments tool on the dialog box and enter comments you want associated with the model.

5. Select OK.

2.5.7 Displaying Models in the Database

The user can set a view window so it displays a particular model in the current modeling database. This is helpful when one
wants to compare different models or work with different models at the same time. To display a different model in a view
window:

1. Click the view window in which you want to display the model.

2. On the View menu, select Model. The Database Navigator appears listing the current models in your modeling
database.

3. Select the model you want to display from the Database Navigator.

4. Select OK.

2.5.8 Renaming a Model

1. On the Build menu, point to Model, and then select Rename. The Database Navigator appears.

2. Select the model to be renamed. The Rename Object dialog box appears.

3. Enter a new name for the model.

4. Select the More button to display the Database Navigator and rename another object in the database.

5. Select OK.

2.5.9 Deleting a Model

One can remove a model and all its objects from the modeling database. When a model is deleted, Adams/View removes
the following objects from the modeling database:

• Parts

• Geometry

• Markers

• Joints

• Forces

• Simulation results
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• Data and system elements

• Design variables

However, it does not remove plots, interface changes, or design variables that belong to the modeling database. To delete a
model:

1. Do one of the following:

• On the Build menu, point to Model, and then select Delete.
• On the Edit menu, select Delete.

The Database Navigator appears.

2. Select the model to be deleted.

3. Select OK. If Delete selected from the Build menu, Adams/View asks the user to confirm the deletion of the model.

4. Select Delete.

2.5.10 Viewing Model Topology Map

The model topology map displays information about the parts in the model and determines what constraints are owned by
the model and what parts the constraints connect. The information appears in the Information window and in the window
to the right of the Database Navigator. The user can view the part connection information in the following ways:

• By part - Lists each part in the model, along with the parts it is connected to and what constraints or forces are
affecting it.

• By connections - Displays each constraint and force with the parts they connect and act on. Also displays any
unconnected parts.

• Graphically - Displays a representation of the selected part and shows its connections to other parts.

2.6 Basics of Model Building
2.6.1 Parts

Parts define the objects in the model that can have mass and inertia properties and can move. All forces and constraints
that are defined the model act on these parts during a simulation.

• Types of Parts-Adams/View provides three different types of parts that one can create:

– Rigid Bodies
– Flexible Bodies - Basic Adams/View provides the ability to create discrete flexible links. For more functionality,

Adams/Flex must be used.
– Point Masses

In addition, Adams/View provides a ground part that is already created for the user.

About the Ground Part - The ground part is the only part in the model that must remain stationary at all times.
Adams/View creates the ground part automatically when a model is created. The user can also define a new or existing
part as the ground part. The ground part does not have mass properties or initial velocities and does not add degrees
of freedom into the model.

The ground part acts as the global coordinate system that defines the global origin (0,0,0) and reference frame about
which one can create the model. Its position cannot be specified but its geometry can be specified. In addition, by
default, the ground part also acts as the inertial reference frame with respect to which all of the part velocities and
accelerations are calculated. Another part can also be selected as the inertial reference frame through the Command
Navigator. Note that although the ground part is the only part in the model that must remain stationary at all times,
one can move the geometry and constraints attached to the ground part. Since geometry and constraints are tied to
markers, one can use the Select List Manager to select all the markers on ground and then translate and rotate the
ground entities with the rest of the model.

• Local Coordinate Systems - As parts are created, Adams/View assigns a coordinate system to each part, known
as its local coordinate system. A part’s local coordinate system moves with the part and its original position defaults
to that of the global coordinate system. The local coordinate system is a convenient way to define the position and
location of objects. Adams/View also returns simulation results, such as the position of a part, as the displacement of
a part’s local coordinate system with respect to the global coordinate system. It returns object results, however, as
the displacement of a part’s center of mass relative to the global coordinate system.

• Degrees of Freedom - Each rigid body created can move within all degrees of freedom; a point mass can move within
three translational degrees of freedom. One can constrain the movement of parts by:
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– Adding them to the ground part, which means they are fixed to the ground and cannot move in any direction.
Each time one creates geometry, Adams/View gives the option to add it to ground, create a new part, or add it
to an existing part.

– Adding constraints, such as joints, to define how the parts are attached and how they move relative to each other.

• Naming Conventions - As parts are created, Adams/View automatically generates names for them based on their
type and the number of objects of that type in your model. For example, when one creates a point mass, Adams/View
names it POINT_MASS_1. For all rigid bodies, except points and coordinate system markers, Adams/View uses the
name PART regardless of the type of geometry. For example, if one creates a box, Adams/View names it PART_1.
When one creates a second box, Adams/View names it PART_2, and so on. The parts can be renamed.

2.6.2 Some Tools and Techniques

There are several techniques in Adams/View that can help the user create objects with precision and speed.

• Turning Selection Highlighting On/Off - Adams/View provides a Dynamic Model Navigator that highlights
entire objects or edges, faces, and points on those objects so you can easily select, place, or align an object that you are
creating or a rotate a view. The Model Navigator highlights objects and displays their names as you move the cursor
over them within the main window. For example, when you create a marker, the Model Navigator highlights edges,
faces, and points you might want to use to orient the axes of the coordinate system. In addition, if you are adding a
point or joint to a part, the Model Navigator highlights the different parts in your model to which you can add the
point or joint. The figure below shows the the Model Navigator highlighting line geometry. The Model Navigator

Figure 6: Selection Highlighting

only highlights those objects that are appropriate for the operation you are currently performing. For example, when
aligning the faces of two parts, the Model Navigator only highlights faces. It does not highlight edges or points. In
addition, if wire chaining together wire geometry, the Model Navigator only highlights wire geometry. Finally, when
defining a direction, the Model Navigator lets one select points, edges, or faces. When an edge or face is selected, the
Model Navigator then lets one select the direction along the object that you want to define since edges and faces don’t
provide unique direction. To improve performance one can turn off the Model Navigator.

To turn off the Dynamic Model Navigator, during the selection operation, press the Ctrl key.

• Setting Snapping to Objects -As one builds a model through the graphical interface, Adams/View automatically
snaps the object that are being created to surrounding geometric objects. This can help in quickly aligning parts or
draw objects that touch other objects. However, if the working grid is on, when one draws, moves, resize, or reshape
geometry, the geometry automatically snaps to the grid points.

To turn off object snapping, as one creates an object, press the Ctrl key to turn off snapping.

• Entering Precise Location Coordinates-As one creates an object, such as a design point or a force, Adams/View
often asks one to select the position of the object. This can be done graphically by clicking the mouse button when the
cursor is in the screen or the coordinates can be entered precisely set its location. One can enter the location relative
to the origin of the working grid, the global coordinate system, or any other object on the screen. To enter location
coordinates:

1. When Adams/View asks for a location, right-click. The Location Event dialog box appears as shown below. The
current coordinates of the cursor appear in the upper box.

2. In the upper box, enter the coordinates at which to place the object.

3. Select the element (working grid, global coordinate system, or modeling object) to which the coordinates are
relative. By default, the coordinates are relative to the working grid.

4. In the lower box, enter the object to which the coordinates are relative. One only needs to enter an object if the
selected coordinates are relative to an object.

5. Select Apply.
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Figure 7: Entering Precise Location Coordinates

• Selecting from a List of Objects - When one performs a modeling operation, such as set an object’s appearance
or specify a force direction, and you need to select an object from the screen, one can display a list of all objects in
the area surrounding the cursor and then select the desired object from the list. Note that this only works during a
modeling operation. The objects include geometric objects, such as object faces, vertices, and more. To display a list
of all objects in an area of the screen:

1. Right-click the area of the screen containing the desired object. A selection box of all the objects in the area
appears.

2. Highlight the desired object from the list and select OK.
3. As you highlight the desired object in the list, Adams/View also highlights the object on the screen. To see what

objects the names in the list represent, scroll through the list to highlight the objects.

• Geometric Modeling Palette and Tool Stack - These two palettes contain the essential tools required to work in
Adams/View. These may be accessed using the following methods.

– Build→Bodies/Geometry
– Main toolbox→Right-click Geometry tool stack

Displays tools for creating rigid body geometry.

Figure 8: Main Toolbox & Geometry Palette

2.7 Exiting ADAMS
At any point of time, the user may exit from MSC ADAMS environment – On the File menu, select Exit. If the work is
not saved, ADAMS/View asks if the work should be saved. Note: If we accidentally exit without saving the work, one can
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use the Adams/View log file (aview.log) to recover the work, details of which may be obtined from the Adams/View inbuilt
Help or the MSC website.

The above sections are enough for the example that follows. More commands can be obtained from ADAMS Help.

3 Simulating a Four Bar Mechanism
In this section, we move onto a hands on example on how to build and implement the simulation of a simple four-bar
mechanism in ADAMS.

3.1 Process of Performing a Model Simulation in Adams
• Create a New ADAMS Database

• Define the Units and Working Grid size

• Import or Create the Geometry

• Define moving parts in the Model

• Connect the moving parts with Joint connections

• Apply motion to a Joint

• Run a Kinematic Simulation

• Animate Simulation Results

• Plot result values from the Simulation run

3.2 Problem Statement
The chosen Four Bar Mechanism with goemetry is as follows.

Link No. Length(m) Center of Mass(m) Mass(Kg) Inertia(Kgm2)
1(Ground) 1.241 -NA- -NA- -NA-

2 1.241 1.2 20.15 9.6
3 1.200 0.6 8.25 0.06
4 1.200 0.6 8.25 0.06

The initial configuration of the mechanism is when the driven link is at 10°. The mechanism is driven by a preloaded torsional
spring of stiffness 0.1N/radian kept at the dirving joint between link 1 (ground) and link 2. The preload is 1.96Nm and as
the mechanism is released, the spring starts unwinding. The requirement is to compute the motion of the mechanism till (or
just before) the mechanism reaches it next singular configuration.

3.3 Creating a New Adams Database & Define the Units & Working Grid size
1. Launch ADAMS

2. In the Welcome Dialog Box, enter the model name as ’four_bar_sim’(or any other name of your convenience but
without spaces).

3. Enter the units as MKS & Gravity at the default values.

4. Finally select the working directory of your choice. The model files will be stored in the working directory.

5. Select OK.

6. To set the Working Grid properties, goto Settings→Working Grid. Subsequently, enter the values as shown in the
figure below, so as to have a rectangular working grid of size 5m×5m, with grid points at a spacing of 10cm×10cm
squares. Also, toggle the grid display with the check box as shown below.

7. Select OK.
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3.4 Create Geometry
Geometry is usually added to a simulation to enhance the visualization of results of the simulation (Except for contact
analysis where obviously geometry plays the crucial role). As far as the simulation is concerned, ADAMS only requires the
masses, center of mass locations and the inertia properties. However, as mentioned above, it greatly aids in the visualization
of the results.

In our case, the geometry consists of four links connected by revolute joints, one of the links being arrested/ground. The
whole mechanism has one degree of freedom. So, we need to provide the software with the initial mechanism configuration,
which is in turn needs to be constructed precisely. In this case, we use points/markers to lay out your design so that you
can make layout changes by moving the points. These are used to define locations in space on which you can position and
parameterize other objects. Points/markers are the easiest way to parameterize the geometry of a model because they let
one specify important locations once and build other modeling objects from them.

For any mechanism with known geometry & initial conditions, we can accurately construct the mechanism configuration
at the initial instant, very easily. For convenience, we have already calculated the joint locations of the four bar mechanism
with the given geometry & is listed below. Points will be created at these four points so as to aid in easy construction of
geometry.

Point No. X(m) Y(m) Z(m)
1 0.000 0.000 0.000
2 1.221 0.203 0.000
3 2.423 0.208 0.000
4 1.241 0.000 0.000

1. Right-click the Rigid Body tool stack (Link tool is on top by default) to display the tool stack containing the Point
tool.

2. Select the Point tool and do one of the following.

• Click the points specified in the location table above, on the working grid.

• Right click on the Working Grid away from any of the existing entities/markers, on some empty area. The Loca-
tion Event Dialog Box comes up. Here select the Rel. to Origin option and enter the respective coordinates
in the form x,y,z.

• Use the Point Table option seen inside the Point tool stack. Click the Point Table, then select Points radio
button, then click on Create button 4 times to create four table entries. Now, enter the four coordinate locations
from the table, as shown in the figure.

12



Figure 9: Different Methods for Creating Points

For the point tool, use the default settings- Add to Ground and Don’t Attach.

3. Repeat the same procedure for all the coordinate points mentioned in the table above, to create the four points. The
screen should now look like this.

4. Now, rename the four points respectively as joint_1,joint_2,joint_3 & joint_4. Renaming the points helps us to
easily relocate & organize the model. To do this, right-click the points, select the point entity→Rename. Next, enter
the new name as decribed above & select OK. Repeat the same procedure for all the four points. Another option
would be to rename one point, click Apply & then select the next point from the same screen by clicking the Database
Navigator button & then repeating the same procedure.

Figure 10: Adams GUI with Geometry Keypoints

5. Now we’ll create the four links using the points as paramaters/reference points. For this click the Rigid Body:Link
tool on the Main Toolbox or the Geometry Palette.

6. Tick the checkbox for Width-Enter (.05m), tick the checkbox for Depth-Enter (.01m), leave the Length check box
unticked. Also, make the link as New Part (default). Note that the values for the thickness & width are immaterial
as we’ll be manually entering the mass/inertia properties manually at a later stage.

7. Click joint_1 & then joint_2. This creates a link between them. Right-click the link and rename the link as
link_2. Similarly repeat the above procedure to create link_1 between joint_1 & joint_4, link_3 between
joint_2 & joint_3, link_4 between joint_3 & joint_4. Note that, while creating the link_1 alone, as it is the
ground/arrested link in this mechanism, the option for Link tool has to changed from New Part to On Ground.
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8. The completed geometry should look like this.

Figure 11: Adams GUI with Geometry

9. The final step in geometry creation is to create an additional marker for Centre of Mass of link_2. As clearly visible
from the table, the Centre of Masses for all except the link_2 (driven link) are at their respective centers. But link_2
has CM at a distance of 1.2m from joint_1 along the link. So we have to define a point at the new CM location.
However,being the CM location, ADAMS also calculates/stores the Inertia values along the principle axis which in turn
are given by the CM marker orientation. Hence we have to create a marker(a coordinate system) at this point and we
will be later providing this as the modified CM marker for link_2.

10. To create the marker, select the Marker tool , then select the options as Add to Part & X, Y Axis. The second
option means that, we’ll be specifying the X & Y axes of the Marker Coordinate system during the marker creation
process.

11. Now, a look at the Status Bar at the bottom of the GUI window, shows the software asking to pick the body. Select
link_2.Now, it will ask for Location of Marker. Right-click on some empty area of the working grid to activate the
Location Event dialog box. Then selectRel. to Object option, and then in the bottom most input field, right-click &
selectAll→Browse. This brings up theDatabase Navigator.From this, goto four_bar_simulation→ then select
the joint marker attached to link_2 & aligned with the LCS(Local Coordinate System) of link_2(MARKER_1 in
this case), as shown below. Then enter the coordinates 1.2,0,0 in the topmost input field. Select Apply. Now, Adams
will ask for the Marker orientation. For both the X & Y axis vectors, mouse pick the respective LCS axis vectors of
link_2. The marker will be created oriented along the link_2 LCS.

12. Finally, rename the marker as link2_cm_mod. Figure below shows the link2_cm_mod in Magenta whereas
reference marker(MARKER_1) is shown in Yellow.

13. Save the Database.

Figure 12: Creating the New CM Marker for link_2

Note: To repeatedly apply any tool without pressing the respective tool button again, double-click the tool. To deselect
the tool, select the Select tool and press the Esc key.
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3.5 Define the Mass & Inertia properties of the links
ADAMS solver provides users with options to input material density or material type (steel, aluminium etc.) for each
part, in which case it uses the geometry information to calculate the masses, inertia tensor components & location of center
of mass. It also provides a third option called User Input wherein the user can input the inertia tensor components, mass
and center of mass location. We’ll be using the third option to input the inertia/mass properties earlier mentioned in the
problem statement. For the given problem, the four rigid bodies are assumed to be cuboids. So, as per ADAMS LCS (Local
coordinate System) for link_1, clearly the figure shows that X axis is aligned along link, Y axis perpendicular to the link
in-plane. Being a two-dimensional problem, the dynamics take place in XY plane rotations takes place about the Z axis.
The given inertia values are Izz values.

These simplifications should be done independently for each of the four links, as the LCS orientations may be different
for each case and consequently the non-zero terms in the inertia tensor might change. Note that the LCS orientation is the
orientation of the CM marker for each part/link.

Figure 13: LCS of each of the three links highlighted

1. Right-click link_1 & select part→Modify. The Modify Body dialog box appears. In this for field Category, select
Mass Properties. For field titled Define Mass by, select User Input. The Mass and Inertia tensor input fields
appear below immediately, along with the Center of Mass Marker field. Enter the values as mentioned in the table
mentioned in the problem statement. For example, link_1 has Mass of 20.15Kg and Izz = Iyy = 9.6Kgm2. In
addition, for link_1, modify CM marker field, by right-clicking it, selecting Marker→Guess. This opens up the
Database Navigator, from where the Marker link2_cm_mod is selected. After filling, the dialog box should look like
the following.

Figure 14: The Modify Body Dialog Box

3.6 Define and Connect the Moving parts with Joints
Now that we have the geometry, it’s time to define the joint connections. The four bar mechanism has four revolute joints
at each of the link interfaces. In Adams, Revolute Joint tool is accessible from the second row of the Main toolbox or from
the Joints Palette.

1. To create the revolute joints, first select the Revolute Joint tool . Allow the tool options to stay at defaults.
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2. Subsequently, using the messages in status bar as guide, pick the first body(link_1) & then follow by the second
body(link_2). Finally, create the joint by specifying the location of the joint at joint_1 marker. Adams displays the
rotary joint as a Anti-Clockwise arrow. Note that the order of picking does not affect the joint characteristics in any
manner. Now, rename the rotary joint as revolute_1.

3. Repeat the same procedure to create revolute joints revolute_2, revolute_3 & revolute_4.

3.7 Define sensor & Measures & Apply Preload torque
Once the revolute joint definition is complete, the mechanism definition is complete. Now, we need apply the preload
torque at the driven joint. Once the preload torque is applied, we may run the simulation and plot the results. ADAMS
solver computes the default set common parameters like accelerations, velocities and configurations of the mechanism for the
simulation time. However, if we are to measure some particular parameter which is not part of the default set, then we have
to define them as measures.

A measure lets you investigate several predefined and user-defined characteristics of the model during or after a simulation.
For example, one can use a measure to find the angle between two links connected by a revolute joint, the X component of
relative velocity between two parts, and more. There are two types of measures available:

• Predefined measures that automatically output information.

• User-defined measures that one can define to obtain more specific information about the model.

We’ll be defining two additional user defined measures for angles in this simulation. It’ll extract information about two
included angles required in this simulation, one of which will be used to create a function for driving torque and the other
will be used for setting up a sensor to sense singularity condition, so as to stop the simulation at the appropriate time. We’ll
use the included angle measure which captures the instantaneous angle between two vectors defined by three markers.

3.7.1 Measure for included angle between ground & link_2 to use in Driving Torque Function

1. From the Measure tool stack on the Main toolbox, select the Included Angle tool.

2. Using the left mouse button, select the following markers:

• The marker that defines the tip of the first vector, in this case joint_4.

• Second marker that defines the vertex, in this case joint_1.

• Marker that defines the tip of the second vector, in this case joint_2.

3. Rename the measure as torsion_spring_angle.

4. Another alternative would be to use Build menu→Measure→Angle→New.

3.7.2 Measure for included angle between link_4 & link_3 to use in Singularity Sensing

1. From the Measure tool stack on the Main toolbox, select the Included Angle tool.

2. Using the left mouse button, select the following markers:

• The marker that defines the tip of the first vector, in this case joint_4.

• Second marker that defines the vertex, in this case joint_3.

• Marker that defines the tip of the second vector, in this case joint_2.

3. Rename the measure as sing_angle.

4. Another alternative would be to use Build menu→Measure→Angle→New. To modify a measure, use

Build menu→Measure→Angle→Modify.

Note: While selecting the markers, a better way would be to rightclick on the desired location & select the proper marker
from the popup selection menu.

3.7.3 Defining a Sensor to sense singularity of the mechanism & stop the simulation

Clearly, when the sing_angle attains a value of π radians, the mechanism reaches a singular configuration. A sensor
monitors a simulation for a specified event and changes a set of simulation controls when the event occurs. So, in order to
avoid singularity, we define a sensor which will monitor the sing_angle and stop the simulation at pi radians.

1. From the Simulate menu→Sensor→New.

2. Set Event Definition to Run-Time Expression.

3. Click the Function Builder button on the right of the Expression input field. The Function Builder pops up.
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4. We have to feed in the event as the point when sing_angle measure crosses 180 degree from bottom, ie when
sing_angle≥ 180. For this, select Measures from the drop down menu below Getting Object Data following
which right-click the input field next to it and select Runtime_Measure→Browse... Now choose sing_angle from
Database Navigator window that opens up. Then select OK & click Insert Object Name in the Function Builder.
Now click OK.

5. Check the Non-Angular Values option, select greater than or equal. In the value field enter 180. Give a tolerance
value ≤ 10−4.

6. In the standard actions list, tick the last option, namely Terminate current simulation step and... Select OK.

7. Sensor is now defined.

3.8 Run the Simulation & review the results
Moving on to the last step, we have to define the simulation time, number of time steps required.

1. Select Interactive Simulation tool from the Main Toolbox . Select End Time as 14 seconds, Steps as 150.

2. Click the Simulate button .

3. If all the above steps have been done properly, you should see the mechanism moving for sometime & finally a popup
message coming up after the animation stops, stating that the simulation stopped after certain time. We can clearly see
that though simulation time of 14 seconds was provided, as the mechanism reaches singular configuration, the sensor
will sense this and cause the simulation to stop within the error tolerance specified there.

4. Now, we may replay the movie using Review Menu→Animation Controls...

5. To plot the results select the Plotting Tool from the Main toolbox . This opens up the Adams/View Post
Processor Window, wherein one can select the data set needed to plot & select Add Curves to plot them & Clear
Plot to clear the plot once review is completed. Options have also been provided to export the plots in different
formats, details of which are available from MSC Online help or MSC Adams/View official help.

4 Concluding Remarks
The above example is given to introduce a new user to MSC.Adams. A word of caution would be very much apt at this
point. ADAMS is only a software. Like any software, wrong input give rise to wrong results and judgement must be used to
verify if the results make sense.
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